Teeworlds

Support

Support and Contact

FAQ

Rules

Support Rules

IRC Rules

Forum Rules

Game Information

CTF Scoring

Common Problems

Reset Config

Compiling Teeworlds

Client

Client Settings

Client Commands

Client Config

Server

Server Setup

Server Config

Server Settings

Server Commands

Server Tuning

Hacking and Development

Hacking on source

Map Editor Reference

CommunityWeb

User Registration Ideas

Other

Donations

Topics that matricks is tired of discussing and will not discuss any more

www.teeworlds.com - Copyright (C) Magnus Auvinen - Contact us!


When using the forum, be sure to read the Forum Rules.

When any of the IRC channels, be sure to read the IRC Channel Rules.

Support

If you run into troubles with running Teeworlds, there is a section in the forum called Support were you can get help from other players and from the developers. There is also an IRC channel on the Quakenet network called #teeworlds for general chatter and support.

Development and supplying patches

If you want to help with the development, we suggest that you start at http://teeworlds.com/trac/teeworlds/wiki/Hacking.

The contact e-mail

The contact@teeworlds.com email address is intended for serious business only. We will not give support related to running the game, server hosting, compiling the game, etc. Take those questions in the forum. Keep in mind when using this address that we only can speak English (preferred) and Swedish.


Running the game

Q: Why doesn't the game start? This is the first time I run it.

A: The game uses OpenGL todo the acceleration. Make sure that you have installed the latest drivers for you graphics card.

Q: The game stopped working, how do I fix it?

A: Probably someone have gone wrong with the with the config. Delete the config-file. Here is how.

Q: I have Graphical errors, white and rainbow textures, low FPS etc

A: Try these following solutions:

  • Delete the config-file. Here is how.
  • Make sure that you have the latest drivers for your graphics card installed.
  • Make sure that you have unpacked everything.
  • Make sure that you start the game from it's own directory.

Server related

Q: How do I setup a server?

A: See the Setting up a server page.

Q: How do I setup a server on Mac OS X?

A: You can't setup a server using Mac OS X at the current moment because of problems with the way it handles application bundles. We will fix this in upcoming releases.

Why isn't my server listed?

A: The server or router isn't configured right.

  • Make sure that you have the line
    sv_register 1
    in your config.
  • Make sure that you have forwarded ports from your router. http://portforward.com/ has a lot information on how to do this.
  • Make sure that your router supports internal connections to the external ip, to be able to see a local server in the Internet tab.

Why doesn't my server start?

A: You probably configured something wrong.

  • Make sure you use a map that is in the data/maps-folder in the teeworlds directory, otherwise it wont work.
  • Make sure the port isn't used.

Hacking the source

Q: How do I compile the source?

A: There is a separate document for this located here.

Other

Q: When is 0.5.0 going to be released?

A: When it's done.


First of all, you need to determine where to go. These are all the various ways of getting support.

The Forum

The Forum is to be used for all and any issues related to installing, building, setting up or playing the game. The support sub-forum is primarily run by the community, but a developer might answer your question if there is no prior information on the subject. Search properly before you ask! If no-one responds to your post, it's very likely that your issue has been addressed before, and that you just suck at searching. Also read the Forum rules.

The IRC channel

This is the preferred way for asking about minor issues, or general game information. You will under no circumstance be given "personal" support from any of the developers -- all questions are to be made in the public channel, so that all can help out. For further information, see the IRC rules.

Contacting the developers

The contact e-mail is not intended for support of any kind. It is very unlikely you will get a reply.

Things you'll never get help with

  • Server hosting
  • Security issues
  • Compiling / porting the game to unsupported platforms
  • Settling player disputes ("abuse")
  • Unofficial modifications of the game, or custom servers
  • Anything not written in English


IRC Rules

These are the rules for #teeworlds on Quakenet

  • Follow quakenet rules, you can find them at http://www.quakenet.org/faq/faq.php?c=136
  • Speak english, so everyone can understand what you say.
  • Be relevant, this is not a a channel about anything, it's about teeworlds.
  • Don't priv msg, if anyone knows and have time, they will answer any question posted in the channel, so everyone can see it.
  • Don't advertise about other channels/goods/websites except if it's relevant to the discussion.
  • No away msg, we don't care where you went.
  • (No away nicks), not a hard rule, but it's just unnecessary with away nicks.
  • No auto-rejoin, it's just rude. It's punishable with a swift new kick and ban.
  • No begging, don't beg for voice, op etc, it's just rude and counter productive.
  • Ops are never wrong, if they are, they are still right.

Punishments starts with a kick and can lead to a temporary ban. If the offense is severe, there will be a permanent ban.


Forum Rules

These are the rules and the moderation guidelines for the forum. Note that moderators may always take any action they deem necessary, considering the circumstances. Breaking a rule is always a bannable offense.

Before posting

1. Use the search function

  • Chances are your issue has already been addressed

2. Never post the same topic in two or more forums

  • The thread in the least relevant forum will be closed

When posting

1. Write in English -- No exceptions!

  • Non-english threads will be closed, non-English posts will be deleted

2. Post in the correct forum

  • Threads will be moved to an appropriate forum

3. Write clear and concise topics

  • Moderators may edit topics to clarify questions

4. Don't post or link to offensive/pornographic/illegal material

  • Threads and posts will be immediately closed. Breaking this rule will very likely result in a ban

5. Respect the other forum members, moderators and developers

  • Moderators may delete offensive posts and ban users at their leisure

6. Stay on topic

  • Spam, "me too"-posts and similar content of low information value may be deleted. Use the signal system.

Forum Moderation

1. Use the signal system

  • If the post doesn't clearly violate forum rules, it will not be removed. If a post has enough negative votes, it will be hidden. Don't forget to reward good posts!

2. Use the report function

  • Do NOT add to the fire by commenting on the offending post. You're just adding to the problem, and you'll risk a warning or a ban.

3. Do not discuss moderation publicly

  • Any issues with moderation should be resolved by PM:ing the moderator, or contacting him / her on IRC. Posts concerning moderation will be removed.

4. Moderators have final say in all matters

  • Remember the golden rule: Moderators are always right, even when they're wrong.


Team score

  • +1 for taking the flag from the flag stand
  • +100 for capture

Player score

  • +1 for taking the flag from the flag stand
  • +1 for returning the flag
  • +1 for fragging the enemy flag carrier
  • +5 for capturing the flag
  • +1 for fragging an enemy
  • -1 for killing a teammate or yourself


Running the game

The game doesn't start, first launch

The game uses OpenGL todo the acceleration. Make sure that you have installed the latest drivers for you graphics card.

The game stopped working

  • Delete the config-file. Here is how.

Graphical errors, white and rainbow textures, low FPS etc

  • Delete the config-file. Here is how.
  • Make sure that you have the latest drivers for your graphics card installed.
  • Make sure that you have unpacked everything.
  • Make sure that you start the game from it's own directory.

Setting up a server

How to setup a server

See the Setting up a server page.

How to setup a server on Mac OS X

You can't setup a server using Mac OS X at the current moment because of problems with the way it handles application bundles. We will fix this in upcoming releases.

My server doesn't get listed

Make sure that you have forwarded ports from your router. http://portforward.com/ gives a lot information on how to do this.


Resetting the configuration

This is done by deleting the configuration file called settings.cfg. This will force the game to use the predefined defaults within the executables.

Windows

Double click on the config_directory.bat. This will take you to the directory where the config-file is stored. Delete the settings.cfg file.

Linux/*nix

The config-file is stored at ~/.teeworlds/settings.cfg. Just run this command from a terminal to delete it.

# rm ~/.teeworlds/settings.cfg

OSX

Delete settings.cfg in ~/Library/Application Support/Teeworlds.


Compiling Teeworlds

IMPORTANT NOTE: Teeworlds requires python 2.x to compile. Python 3.0 will not work.

FAQ

Q: How do I get rid of these errors?

undefined reference to `__stack_chk_guard'

Remove

-fstack-protector -fstack-protector-all

from default.bam in Teeworlds root directory and then run

../bam/src/bam -c all

Windows

Setup

1. Download and install Visual C/C++ Express (http://www.microsoft.com/express/download/default.aspx)
2. Download and install Python (http://www.python.org/download/). the 2.x version, not 3.x
3. Download and unzip bam 0.2.0 (http://teeworlds.com/trac/bam/browser/releases/bam-0.2.0.zip?format=raw)
4. Download and unzip teeworlds (http://www.teeworlds.com/?page=downloads)

Compiling bam

Run in cmd (start>run>cmd):

cd bam
make_win32_msvc.bat
cd ..

Compiling teeworlds

Run in cmd (start->run->cmd):

%comspec% /k ""C:\Program Files\Microsoft Visual Studio 9.0\VC\vcvarsall.bat"" x86

cd teeworlds-version-src

..\bam\src\bam release

for all stuff,

..\bam\src\bam server_release

for server only,

..\bam\src\bam debug

for debug version of all,

..\bam\src\bam server_debug

for debug version of server.

Linux / Mac

Setup

On Linux

Use your package manager (apt-get, emerge or whatever is used on your distro) to install the following: (python is the only one which is required to build server)

python
alsa (asound)
gl
glu
x11

On Mac OS X

Install the XCode tools from apple, make sure to install the 10.4 SDK with it. Download libsdl from the http://libsdl.org and put SDL.framework in /Library/Frameworks

Getting the source

Run the following commands to download and unzip bam and teeworlds:
Replace VERSION in teeworlds-VERSION-src.zip with the version you want (probably the latest, 0.5.0)

$ fetch http://teeworlds.com/trac/bam/browser/releases/bam-0.2.0.zip?format=raw
$ unzip bam.zip
$ rm bam.zip
$ fetch http://teeworlds.com/files/teeworlds-VERSION-src.zip
$ unzip teeworlds-VERSION-src.zip
$ rm teeworlds-VERSION-src.zip

Compiling bam

$ cd bam
$ ./make_unix.sh
$ cd ..

Compiling teeworlds

$ cd teeworlds-VERSION-src

$ ../bam/src/bam release

for all stuff,

$ ../bam/src/bam server_release

for server only,

$ ../bam/src/bam debug

for debug version of all,

$ ../bam/src/bam server_debug

for debug version of server.


Client Settings

There are lots of client settings available, and this doc will guide you through them. If you are looking for client commands, read the Client Commands doc. To find out how to find the config file, read the Client Config doc.

Engine settings

* means added in 0.5.0. If there's one with * and one without, the one without is the 0.4.3 version.

player_name

The name of the player. (default: nameless tee)

password

Password to the server. (default: )

logfile

Filename of the logfile. (default: )

cl_cpu_throttle

Adds a sleep of one millisecond. (default: 0)

cl_editor

Activates the editor. Can't be set in config. (default: 0)

b_filter_string

Server browser filter string. (default: )

b_filter_full

Filter out full servers in server browser. (default: 0)

b_filter_empty

Filter out empty servers in server browser. (default: 0)

b_filter_pw

Filter out password protected servers in server browser. (default: 0)

b_filter_ping

Filter out servers with higher ping than this. (default: 999)

b_filter_gametype *

Filter out other gametypes than this one. (default: )

b_filter_gametype

What gametypes to show. (default: )

b_filter_tuned *

Filter out tuned servers in server browser. (default: )

b_filter_compatversion

Filter out non-compatible servers in server browser. (default: )

b_sort

Column id to sort after. (default: 0)

b_sort_order

Sort order. 0 is ascending and 1 is descending. (default: 0)

b_max_requests

Number of requests at one time used when refreshing server browser. (default: 10)

snd_rate

Sound mixing rate. (default: 48000)

snd_enable

Enables sound. (default: 1)

snd_volume

Sound volume. (default: 100)

snd_device

Sound device. (default: -1)

snd_nonactive_mute

Mutes when Teewolds is inactive. (default: 0)

gfx_screen_width

Screen resolution width. (default: 800)

gfx_screen_height

Screen resolution height. (default: 600)

gfx_fullscreen

Fullscreen. (default: 1)

gfx_alphabits

Alpha bits for framebuffer (fullscreen only). (default: 0)

gfx_color_depth

Color bits for framebuffer (fullscreen only). (default: 24)

gfx_clear

Clear screen before rendering. (default: 0)

gfx_vsync

Vertical sync. (default: 1)

gfx_display_all_modes

Shows all screen resolutions in graphics settings. (default: 0)

gfx_texture_compression

Texture compression. (default: 0)

gfx_high_detail

High detail. (default: 1)

gfx_texture_quality

Quality textures. (default: 1)

gfx_fsaa_samples

FSAA samples. (default: 0)

gfx_refresh_rate

Screen refresh rate. (default: 0)

gfx_debug_resizable

Enables resize of the window (debug only). (default: 0)

gfx_finish *

- (default: 1)

inp_mousesens

Mouse sensitivity. (default: 100)

debug

Debug mode. (default: 0)

dbg_stress

Stress systems. (default: 0)

dbg_stress_network

Stress network. (default: 0)

dbg_pref

Performance outputs. (default: 0)

dbg_graphs

Performance graphs. (default: 0)

dbg_hitch

Hitch warnings. (default: 0)

dbg_stress_server

Server to stress. (default: localhost)

Game settings

cl_predict

Predict movement of players. (default: 1)

cl_nameplates

Show nameplates. (default: 0)

cl_nameplates_always

Always show nameplates. (default: 0)

cl_autoswitch_weapons

Auto switch weapon when picking up. (default: 0)

cl_showfps

Displays fps. (default: 0)

cl_airjumpindicator

Makes feet darker when double jump is made. (default: 1)

cl_threadsoundloading

Loads the sound in threads. (default: 0)

cl_warning_tuning

Warning if the server is tuned. (default: 1)

cl_warning_teambalance *

Warning if teams are unbalanced. (default: 1)

cl_prompt_teambalance

Warning if teams are unbalanced. (default: 1)

cl_mouse_deadzone

How far from the player you can move the mouse without camera moving with you. (default: 400)

cl_mouse_followfactor

Set how fast the camera will follow the cursor. (default: 60)

cl_mouse_max_distance

Max distance between mouse and player, before camera movement. (default: 800)

ed_showkeys

Shows the key presses in editor. (default: 0)

cl_flow

Enables client flow. (default: 0)

cl_show_welcome

Shows the first launch popup. (default: 1)

cl_motd_time

How long the motd is showed. (default: 10)

cl_version_server

Version checking server. (default: version.teeworlds.com)

player_use_custom_color

Toggle use custom colors on/off. (default: 0)

player_color_body

Player body color. (default: 65408)

player_color_feet

Player feet color. (default: 65408)

player_skin

Player skin. (default: default)

ui_page

Interface page. (default: 5)

ui_server_address

Interface server address. (default: localhost:8303)

ui_scale

Interface scale. (default: 100)

ui_color_hue

Interface color hue. (default: 160)

ui_color_sat

Interface color saturation. (default: 70)

ui_color_lht

Interface color lightness. (default: 175)

ui_color_alpha

Interface alpha. (default: 228)

dbg_dummies

Number of dummies to spawn at the map. (default: 0)

dbg_tuning

Shows tuning of a server. (default: 0)


Client Commands

There are lots of client commands that can be executed in the console, or in the configuration file. This doc shows them all. If you look for client settings, read the Client Settings doc. To find out how to find the config file, read the Client Config doc.

Console

All these commands can be executed in the console. To open the console, press the console-key (f1 is default).

* means that it's introduced in 0.5.0.

Engine commands

echo

Syntax: echo text Prints out the text to the console.

exec

Syntax: exec file Executes the commands in the specified file.

quit

Syntax: quit
Quits the game.

connect

Syntax: connect host:port[[BR]] Connects to the specified server.

disconnect

Syntax: disconnect
Disconnects from the server.

ping

Syntax: ping
Pings the server.

screenshot

Syntax: screenshot
Takes a screenshot.

rcon

Syntax: rcon command
Executes the command in rcon.

play *

Syntax: play filename
Plays the file in the demo player.

record *

Syntax: record filename
Starts a recording to the specified file.

stoprecord *

Syntax: stoprecord
Stops the recording.

add_favorite *

Syntax: add_favorite host:port[[BR]] Adds the server as a favorite.

Game commands

+left

Syntax: +left
Moves to the left.

+right

Syntax: +right
Moves to the right.

+jump

Syntax: +jump
Makes a jump.

+hook

Syntax: +hook
Fires hook.

+fire

Syntax: +fire
Fire a shot.

+weapon1

Syntax: +weapon1
Switches to weapon 1 (hammer).

+weapon2

Syntax: +weapon2
Switches to weapon 2 (gun).

+weapon3

Syntax: +weapon3
Switches to weapon 3 (shotgun).

+weapon4

Syntax: +weapon4
Switches to weapon 4 (grenade launcher).

+weapon5

Syntax: +weapon5
Switches to weapon 5 (rifle).

+nextweapon

Syntax: +nextweapon
Switches to the next weapon.

+prevweapon

Syntax: +prevweapon
Switches to the previous weapon.

callvote *

Syntax: callvote type value
Calls a vote about the specified type and value.

vote *

Syntax: vote yes/no
Votes yes or no.

+emote

Syntax: +emote int

emote

Syntax: emote int

+scoreboard

Syntax: +scoreboard
Shows the scoreboard.

say

Syntax: say message
Sends a global chat message.

say_team

Syntax: say_team message
Sends a chat message to the team.

chat

Syntax: chat all/team
Enables chat in the chosen mode.

bind

Syntax: bind key command
Binds the command to the key.

unbind

Syntax: unbind key
Unbinds the key.

unbindall

Syntax: unbindall
Unbinds all the keys.

dump_binds

Synax: dump_binds
Dumps the binds.

toggle_local_console

Syntax: toggle_local_console
Toggles the local console.

toggle_remote_console

Syntax: toggle_remote_console
Toggles the remote console.

team

Syntax: team newteam
Switches to the desired team.

kill

Syntax: kill
Kills yourself.


Client Config

To find the configuration file for Teeworlds, you can read this guide. If you want to configure the client, check out Client Settings. If you want to find the client commands available, see Client Commands. The client configuration file is located in different locations depending on the operating system.

Windows

Run the file called config_directory.bat, that can be find in the Teeworlds directory, or enter directly

%APPDATA%\Teeworlds

in an explorer window.

Linux

The config file is located in ~/.teeworlds

Mac OSX

The config file is located in ~/Library/Application Support/Teeworlds


Server Setup

This doc will guide you through the basics of setting up a server on Linux and Windows.

Port forwarding

If you want other players to be able to play on the server via internet, you have to forward a port to the server. http://portforward.com/ has a lot information on how to do this.

Configuring the server

To configure the server you need to create a .cfg-file so that the server knows what to do. Use your favorite text editor to create a config that uses the following syntax:

setting value
setting2 value2

To find the available settings, read the Server Settings doc.

Starting the server

To start the server you must specify a config for it to load. This is done by adding the flag "-f" to the server start command, like this:

teeworlds_srv -f serverconfig.cfg

Windows

Start the command tolk by pressing Windows key+R, write "cmd" followed by enter, and use the command "cd" to get to the teeworlds directory.

When you get there, start the server by typing

teeworlds_srv.exe -f serverconfig.cfg

where you replace "serverconfig.cfg" with the name of your config file.

Linux

Open up a terminal and use the command "cd" to enter the teeworlds directory.

To start the server, type

teeworlds_srv -f serverconfig.cfg

where you replace "serverconfig.cfg" with the name of your config file.

Remote console

To be able to execute server commands while playing, there is a remote console. To open it, press f2 (or the key you have chosen). You will now be asked to enter a password. If the console says that there are no password, you have to set the sv_rcon_password variable to enable that. Read more about it in the Server Settings doc.

To find out what commands that are available on the server, read the Server Commands doc.

Support

If you have any questions, read the FAQ. If you can't find an answer, please use the support forum.


Set up a server

  • Configure firewall/nat/router to let though 8303 (or the port you want). The master server will warn if players can't connect. Check http://portforward.com for help on setting up your router.
  • Create a configuration for your server. Add the settings you want (each line in the config represents a setting).
  • Start the server by running "teeworlds_srv -f my_server_config.cfg"

FAQ

Q: How do I setup a LAN server?

Set sv_register to 0. This will make sure that it doesn't show up on the internet tab.

Q: Why doesn't my server show up in the server browser?

You have probably not setup your router correctly. See http://portforward.com for help.

Q: Why doesn't my 0.x.x-config work in 0.4.x?

The configuration file syntax has changed. Try replaceing all the = with space, and read this documentation.

Example configurations

Sample DM config

sv_name Teeworlds sample dm
sv_map dm1
sv_scorelimit 20
sv_timelimit 10
sv_gametype dm
sv_rcon_password remember
sv_motd Teeworlds sample dm configuration
sv_max_clients 12
sv_spectator_slots 10

Sample TDM config

sv_name Teeworlds sample tdm
sv_map dm6
sv_scorelimit 50
sv_gametype tdm
sv_rcon_password remember
sv_motd Teeworlds sample tdm configuration

Sample CTF config

sv_name Teeworlds sample ctf
sv_map ctf2
sv_scorelimit 400
sv_gametype ctf
sv_rcon_password remember
sv_motd Teeworlds sample ctf configuration

Server Settings Reference

Syntax: setting value

sv_name

This is the name of the server which will show up in the server browser. (default: unnamed server)

sv_map

The map that is chosen when starting the server. (default: dm1)

sv_maprotation

Used to specify multiple maps which rotates after the time or score limit is reached. (default: )

sv_warmup

Warmup time in seconds before the game starts. If it is set to 1 it will start immideatly. (default: 1)

sv_scorelimit

What score that should be reached to end the game. Don't forget to set this to zero if you want a timebased limit. (default: 20)

sv_timelimit

The time in minutes before the game ends. (default: 0)

sv_gametype

What gametype, could be dm, tdm or ctf. (default: dm)

sv_port

The server's binding port. (default: 8303)

sv_rounds_per_map

Set number of rounds. Map will be changed after last round ends. (default: 1)

sv_register

Whether the server should register on the masterserver or not (if on, it will show up in the server list). (default: 1)

sv_rcon_password

Password to access the remote control (rcon). (default: )

sv_motd

Message of the day, shows when joining the server and under the server info-tab. (default: )

sv_max_clients

Number of clients which can be on the server. This can't be changed without restart. (default: 12)

sv_spectator_slots

Number of all the slots that should be spectators. (default: 0)

sv_teambalance_time

The time in minutes after the teams are uneven to use auto balance. (default: 1)

sv_spamprotection

Turning on/off spam filter. (default: 1)

password

Password to join the server. (default: )

sv_tournament_mode

If this is on, player automatically join spectators when entering a server. (default: 0)

sv_teamdamage

If teammates will hurt each other or not. (default: 0)

sv_powerups

If this is off ninja is disabled. (default: 1)

sv_bindaddr

Address to bind to. (default: )

sv_external_port

What port the server reports to the master servers in cases of firewall rename/redirection rules. (default: 0)

sv_high_bandwidth

Doubles the snap rate, the game gets a bit more responsive but it requires more than doubled bandwidth. Only recommended for LAN-servers. (default: 0)

Server commands reference

kick

Syntax: kick id
Kicks the user with the specified id out of the server.

status

Syntax: status
Shows client stats and ids.

restart

Syntax: restart value
Null the score and starting warmup timer (depends on the value). If no value, then new round begins instantly.


Server Settings

There are lots of server settings to change all from the score limit, to the speed of the shotgun. This doc will show you what those are, not how to set up a server. Read the Server Setup doc to learn that. For server commands, see the Server Commands doc.

Syntax: setting value

Physics settings

To change the game's physics, read the Server Tuning doc.

Engine settings

* means it can't be changed while running the server.

sv_name

Sets the server name which will be shown in the server browser and on the server info page. (default: unnamed server)

sv_bindaddr *

Address to bind to. (default: )

sv_port *

Select the port the server listen to. (default: 8303)

sv_external_port *

Port to report to the master servers (in case of firewall renam e)

sv_max_clients *

Number of clients that can be on the server at the same time. (default: 12)

sv_high_bandwidth *

Use high bandwidth mode, for LAN servers only. (default: 0)

sv_register

Registers on the master servers if it's set to 1. (default: 1)

sv_map

Changes map immediately after the command is executed. Use this to set the default map when starting a server. (default: dm1)

sv_rcon_password

Password to access the remote control (rcon). (default: )

sv_map_reload

Reloads the current map. (default: )

Game settings

sv_warmup

Specifies the warmup time before a round will start. Will start immideatly if set to 0. (default: 0)

sv_scorelimit

Tells at what score the round should end. Set to 0 if you only want a time limit. (default: 20)

sv_timelimit

Tells how long a round can go on. If the score is equal by then, there will be a sudden death. (default: 0)

sv_gametype

Select what gametype to use (dm/tdm/ctf/mod). If you want to change this in game, you must use sv_map_reload or sv_map after the command is executed. (default: dm)

sv_maprotation

Used to specify a list of maps which will rotate after the last one has passed. (default: )

sv_rounds_per_map

The number of rounds before changing map. (default: 1)

sv_motd

Message of the day, shown in server info and when joining a server. (default: )

sv_spectator_slots

How many of the max clients-number that will be spectators only. (default: 0)

sv_teambalance_time

The time in minutes after the teams are uneven, to use auto balance. (default: )

sv_spamprotection

Turning on/off spam filter. (default: 1)

sv_tournament_mode

Players will automatically join spectator. (default: 0)

sv_teamdamage

Turns on friendly fire. (default: 0)

sv_powerups

Set to 0 to disable powerups. (default: 1)

sv_vote_map

Enables map voting. (default: 1)

sv_vote_kick

Enables kick voting. (default: 1)


Server Commands

To kick players from the server and to do other similar things, you have to use the server commands. This doc will show you these. If you want to know how to set up a server, read the Server Setup doc. For server settings, see the Server Settings doc.

Commands

* means introduced with 0.5.0

echo

Syntax: echo text
Prints out the text to the console.

exec

Syntax: exec file
Executes the commands in the specified file.

kick

Syntax: kick id
Kicks the user with the specified id directly.

ban *

Syntax: ban ip
Bans the ip from the server.

bans *

Syntax: bans
Lists the banlist.

status

Syntax: status
Lists the players' id, ip, name and score.

shutdown

Syntax: shutdown
Shuts down the server.

record *

Syntax: record filename
Start a recording to the file.

stoprecord *

Syntax: stoprecord
Stops the recording.

tune

Syntax: tune variable value
Tunes the variable. See the Server Tuning doc.

tune_reset

Syntax: tune_reset
Resets the tuning to default.

tune_dump

Syntax: tune_dump
Makes a dump that shows what tuning that's used.

change_map *

Syntax: change_map mapname
Changes to the specified map.

restart

Syntax: restart time
Restarts the round. Time is optional.

broadcast

Syntax: broadcast text
Broadcasts the text.

say

Syntax: say text
Sends a chat msg.

set_team

Syntax: set_team client_id team
Sends the player with the specified id to the team.

addvote

Syntax: addvote option
Adds a vote option for the provided option.

vote

Syntax: vote yes/no
Forces the end result of the vote to yes/no.


Tuning reference

Tuning is a way to edit physics and weapon settings so that the server is more customizable. To tune a variable, execute the following in rcon or config:

tune gravity 1.0

where you replace "gravity 1.0" with the variable and value you want.

Physics tuning

ground_control_speed

Max speed the tee can get on ground. (default: 10.0)

ground_control_accel

Acceleration speed on the ground. (default: 2.0)

ground_friction

Friction on the ground. (default: 0.5)

ground_jump_impulse

Impulse when jumping on ground. (default: 12.6)

air_jump_impulse

Impulse when jumping in air. (default: 11.5)

air_control_speed

Max speed the tee can get in the air. (default: 5.0)

air_control_accel

Acceleration speed in air. (default: 1.5)

air_friction

Friction in the air. (default: 0.95)

hook_length

Length of the hook. (default: 380.0)

hook_fire_speed

How fast the hook is fired. (default: 80.0)

hook_drag_accel

Acceleration when hook is stuck. (default: 3.0)

hook_drag_speed

Drag speed of the hook. (default: 15.0)

gravity

Gravity of the teeworld. (default: 0.5)

velramp_start

Velocity ramp start. (default: 550.0)

velramp_range

Velocity ramp range. (default: 2000.0)

velramp_curvature

Velocity ramp curvature. (default: 1.4)

player_collision

Enable player collisions. (default: 1)

player_hooking

Enable player vs player hooking. (default: 1)

Weapon tuning

gun_curvature

Gun curvature. (default: 1.25)

gun_speed

Gun speed. (default: 2200.0)

gun_lifetime

Gun lifetime. (default: 2.0)

shotgun_curvature

Shotgun curvature. (default: 1.25)

shotgun_speed

Shotgun speed. (default: 2200.0)

shotgun_speeddiff

Speed difference between shotgun bullets. (default: 0.8)

shotgun_lifetime

Shotgun lifetime. (default: 0.25)

grenade_curvature

Grenade curvature. (default: 7.0)

grenade_speed

Grenade speed. (default: 1000.0)

grenade_lifetime

Grenade lifetime. (default: 2.0)

laser_reach

How long the laser can reach. (default: 800.0)

laser_bounce_delay

When bouncing, stop the laser this long. (default: 150.0)

laser_bounce_num

How many times the laser can bounce. (default: 1.0)

laser_bounce_cost

Remove this much from reach when laser is bouncing. (default: 0.0)

laser_damage

Laser damage. (default: 5.0)


Site Name: Teeworlds.com

About this file

Date: 2009-05-27 (game version on this moment was 0.5.1)
Version: 1.2
Languages: English

About author

Name: Anton S.
Forum: Jaranero
Game: *AntofA*